FC2ブログ

Pure Data 続き?

しょっぱなから脱線するけど、OpenSSLとインターネット・エクスプローラーの脆弱性ってちょっとヤバくない?

OpenSSLの脆弱性については、4月11日に対策を含めて一部サイトで注意喚起されていたようだけど、新聞やニュース報道は半月以上後になるのかー。

インターネット・エクスプローラーは、XPのサポートが終わるぞ、ネット接続が危険になるぞと、散々脅してOSの乗換えさせたあとに、いやー実はver.6以降全然ダメだったでござるとか言われても。
まぁ、OSの買い替えが一段落するまで発表を遅らせたんじゃね? と、ちょっと疑いたくなる。

実は、XPで他のブラウザ使ってるほうが、8.1でIEを使うより安全だったりして。



さて、本題の Pure Data、pd-for-android ではなく、本体(?)の Pd-extended 、なぜだか起動時に、

(Tcl)不適切なコマンド名:invalid command name "open:"
while executing
"open:/Library/pd/gem.conf:No such file or directory"
("uplevel"body line 1)
invoked from within
"uplevel #0 $cmds_from_pd"
(Tcl)不適切なコマンド名:invalid command name "open:"
while executing
"open:./gem.conf:No such file or directory"
("uplevel"body line 1)
invoked from within
"uplevel #0 $cmds_from_pd"

とエラーを吐く。
どうやら Gem という描画関係のライブラリーのコンフィグ・ファイルがないとか言ってるらしい。

今のところチュートリアルのコードを試しているだけなので、大した影響はないんですが、起動するたび Pdウィンドウが真っ赤になるのが気になるので、検索してみました。

バグ・レポートを読むと、どうやら 64bitOS に出るエラー・メッセージのようです。
多くは ubuntu の64bit版を使っている人からのレポートでした。

で、公式サイトを見てみると、Pd-extended のダウンロード・ページの一番下に、

Get Pd-extended for Mac OS X
beta 64-bit build,no Gem, hid, etc. and other libraries may have issues.
Only use this if you know what you're doing,or you want to experiment.

問題のライブラリー Gem を含めて色々ライブラリーもないし、他のライブラリーも問題ありそ。
自分が何をしてるか分かってる人か、実験してみたい人以外お断り。とか言ってる気がする。

初心者が手を出せるようなものじゃなさそうですね。

うーん・・・、エラーを吐いても正常に使えれば問題ないんだけど・・・。

とりあえず、 /Library/Pd/ フォルダを作って、公式からサイトから Gem だけダウンロードしてきて、突っ込んでみる。
起動 → 症状変わらず。

では、~/Library/Pd/を作って突っ込んでみる。
起動 → 症状変わらず。


Pd ウインドウのエラーメッセージを読むと、どうも致命的なエラーのようす。
Gem を使うようなプログラムを作らなければ大丈夫なんじゃろか。
といいつつ、初心者すぎて Gem が何をしているかも分からんのですが。

さて、進むべきか、退くべきか。
このまま玉砕覚悟で突き進むか、潔く撤退してGWを他のことして過ごすか。

もう、飲んだくれてればいいじゃんという悪魔の囁きが聞こえる昨今。



スポンサーサイト



コメント

非公開コメント