Pd-for-android でエラー


以前、作ったプロジェクトファイルを開いてみたら、Pd-for-android でエラー。

AndroidMidi は問題ないようで、PdCore にバッテンがついてる。
PdCore のビルド・ターゲット(プロパティ -> リソ-ス -> Android)を AndroidMidi に合わせて Android 3.1 = 12 にしていたんだけど、そうすると、Audioparameters.java の AudioManager.PROPERTY_OUTPUT_SAMPLE_RATE と AudioManager.PROPERTY_OUTPUT_FRAMES_PRE_BUFFER が解決できないとか仰る。

いつもの対処法、ビルド・ターゲット を最新版(16/05/17時点で Android 6.0 = 23)にして、プロジェクトをクリーンしてみたところ、今度は PdService.java の Notification でエラー。
どうやら、Android で Notification 自体が非推奨になってしまったらしい。

とりあえず、ビルド・ターゲットを Android 5.1.1 = 22 にすると、エラーが取れたけど、Pd-for-android を最新版にしたほうが良さそげ。
Github で確認したところ、最新版では対応されている模様。

でさぁ、最新版に更新して、eclipse にライブラリーを追加するのってどうやるんだっけ? と確認しようと思ったら、eclipse が非推奨になってました。
Android Studio を使えって。
そろそろ切替時なのかなぁ。Google の SDK の解説も Android Studio しか記載しなくなってきたし。
まぁ、特化している分、設定は楽なんだろうと思うけど。
スポンサーサイト

コメント

非公開コメント